i.canExecute is not a function bpmn.io


I am facing an issue when i try to run the bpmn application in the prod mode.

I have gone through the above url where similar issue has been addressed.

Workarounds that i tried are

  1. Importing production module of bpmn modeler (Didn’t work)
  2. Making the codeoptimizer to false in angular.json file (Worked)

but they aren’t ideal way to approach this problem.

Please let me know if there are any solution to this issue.

Thanks in advance.

What is the issue you’re facing?


Have you tried something like this: https://stackoverflow.com/questions/52891528/angular-cli-exclude-package-from-optimization ?

You can have the DMN specific part excluded from optimisation.

I am trying to implement few custom rules by importing ruleprovider.js file. When i try to run the application using --prod command i am facing the below issue.

                     **i.canExecute is not a function**

HI oguzeroglu,

I have tried modifying buildoptimizer as well. It works but the problem is that the generated build size exceeds the accepted limit.