Fatal error: spawn cmd ENOENT when I try to build /test with grunt

Hi guys.
I’m new in this blog.
I have some problem with the build of /test after the project install and the download of project dependencies.
When I run the grunt command I obtain this error:
Fatal error: spawn cmd ENOENT in the Running “jsdoc:dist” (jsdoc) task.

Can someone help me to understand what is the problem?

Thank you for the support.


can you please be a little more specific on how to reproduce your problem.

Which specific project are you building?
Which grund command are you running?


Hi @robertgimbel .

The error is reported in the image below.
I follow the instructions reported here.
So I cloned the project, I fetched dependencies with npm install commands, and after, I run the grunt to build /test.

The error occurs when I run the grunt command, in the “jsdoc:dist” (jsdoc) task (so I think the project is “jsdoc”).

could you execute the following command and post the results here?
grunt jsdoc --debug

Hi @pedesen, I tried to run the grunt jsdoc --debug.
This is the result:

Thank you for your help.

Apparently there are some files or dependencies missing… Do you have java installed (which is a dependency of jsdoc)? You can check it in the command line with: java -version

@pedesen yes Java is installed, take a look:

With your answer I understand that there is no jsdoc installed, so I installed it, and I tried to repeat the entire procedure.

Now the error is different as shown below:

Okay, the first issue should be resolved now. This is a different error. You could increase the browser activity timeout.

In the file bpmn-js/test/config/karma.unit.js you can change the value for browserNoActivityTimeout from 30000 to e.g. 100000 and try to run grunt again.

@pedesen another improvement is done.
Now in addition to the phase that caused errors before, the grunt command passes other passes but an error occurred when the jsdoc:dist (jsdoc) task:

The error is ENOENT, another time as in the past, but before it’s caused by jsdoc which is not installed. Now it’s installed so I don’t know the cause of this error.

Hello @Luca_Milioli,

which version of Node are you using ?


Hello @ricardomatias.
The node version is the 0.12.5