Diagram JS from git hub repo is not working


#1

Today I just cloned the diagram JS from git hub. It is throwing errors, it seems I see few changes happening recently, I remember it was working in last week


#2

Mind sharing what errors you’re encountering?


#3

HI I cloned the diagram Js ,
then I ran npm install command to load all dependancies
then I ran the npm run all command , Im getting below errors
image

and error info:
0 info it worked if it ends with ok

1 verbose cli [ ‘C:\Program Files\nodejs\node.exe’,

1 verbose cli ‘C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js’,

1 verbose cli ‘run’,

1 verbose cli ‘all’ ]

2 info using npm@6.4.1

3 info using node@v10.15.3

4 verbose run-script [ ‘preall’, ‘all’, ‘postall’ ]

5 info lifecycle diagram-js-example@0.0.0~preall: diagram-js-example@0.0.0

6 info lifecycle diagram-js-example@0.0.0~all: diagram-js-example@0.0.0

7 verbose lifecycle diagram-js-example@0.0.0~all: unsafe-perm in lifecycle true

8 verbose lifecycle diagram-js-example@0.0.0~all: PATH: C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin;D:\diagram-js-master\example\node_modules.bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Program Files\nodejs;C:\Program Files\Git\cmd;;C:\Users\dell\AppData\Local\Programs\Microsoft VS Code\bin;C:\Users\dell\AppData\Roaming\npm

9 verbose lifecycle diagram-js-example@0.0.0~all: CWD: D:\diagram-js-master\example

10 silly lifecycle diagram-js-example@0.0.0~all: Args: [ ‘/d /s /c’, ‘run-s lint build’ ]

11 silly lifecycle diagram-js-example@0.0.0~all: Returned: code: 1 signal: null

12 info lifecycle diagram-js-example@0.0.0~all: Failed to exec all script

13 verbose stack Error: diagram-js-example@0.0.0 all: run-s lint build

13 verbose stack Exit status 1

13 verbose stack at EventEmitter.<anonymous> (C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\index.js:301:16)

13 verbose stack at EventEmitter.emit (events.js:189:13)

13 verbose stack at ChildProcess.<anonymous> (C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\lib\spawn.js:55:14)

13 verbose stack at ChildProcess.emit (events.js:189:13)

13 verbose stack at maybeClose (internal/child_process.js:970:16)

13 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:259:5)

14 verbose pkgid diagram-js-example@0.0.0

15 verbose cwd D:\diagram-js-master\example

16 verbose Windows_NT 6.1.7601

17 verbose argv “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js” “run” “all”

18 verbose node v10.15.3

19 verbose npm v6.4.1

20 error code ELIFECYCLE

21 error errno 1

22 error diagram-js-example@0.0.0 all: run-s lint build

22 error Exit status 1

23 error Failed at the diagram-js-example@0.0.0 all script.

23 error This is probably not a problem with npm. There is likely additional logging output above.

24 verbose exit [ 1, true ]


#4

It is working fine now , i did below 2 things

1> in diagram-js-master I ran npm install to load dependancies
1> in diagram-js-master/example folder I ran npm install to load dependancies
2>then I go to example folder and run npm start, then it is running


#5

As it is described here: https://github.com/bpmn-io/diagram-js#hacking-the-project

:wink: