Could not find process name 'TaskExampleProcess'


#1

I clone this repository https://github.com/e2ebridge/bpmn into my local.
Then I attempt to follow its README.md to get start.
When I try building a REST server,I find it I Could not find process name 'TaskExampleProcess’
My developemnt enviroment:

Windows 10
npm 3.3.12
node v5.1.0

Problem Reproduction as follows:

[server.js]

/**
 * Copyright: E2E Technologies Ltd
 */
"use strict";

var bpmn = require('../lib/public.js');
var path = require('path');

var port = 9998;
var urlMap = {
    "TaskExampleProcess": path.join(__dirname, "./resources/projects/simple/taskExampleProcess.bpmn")
};

// Returns a restify server.
var server = bpmn.createServer({urlMap: urlMap, logLevel: "debug"});

server.listen(port, function() {
    console.log('%s listening at %s', server.name, server.url);
});

[client.js]

var restify = require("restify");

// This example used the node-restify client
var client = restify.createJsonClient({url: "http://localhost:9998"});

client.post('/TaskExampleProcess', function (err, req, res, obj) {
    console.log(err);
});
  • step1:I run server.js,it has no errors,console ouput as follows
BPMNProcessServer listening at http://[::]:9998
  • step2:Then I run client.js,console ouput as follows:
{ [InvalidArgumentError: Could not find process name 'TaskExampleProcess'.]
  message: 'Could not find process name \'TaskExampleProcess\'.',
  statusCode: 409,
  body: 
   { code: 'InvalidArgument',
     message: 'Could not find process name \'TaskExampleProcess\'.' },
  restCode: 'InvalidArgument',
  name: 'InvalidArgumentError' }

Has anyone ever encountered this problem?What is the reason? How to solve it?
I look forward to your reply.Thanks.


#2

How is your question related to bpmn.io or any of our projects?


#3

This repository https://github.com/e2ebridge/bpmn is a BPMN 2.0 execution engine.
There is some test cases in test folder.
My question is that I *Could not find process name 'TaskExampleProcess* When I run server.js and client.js(I create).
Now I has already solved this problem.So please ignore this post.


#4

Hello wdpm,

How you solve that problem? I’m also facing that problem. Can you please help me to sort it out?