Cannot deploy a Zeebe workflow created in modeler


I’m having some troubles with deploying a workflow built using library. To be more specific Zeebe is complaining on some attributes added by - bioc:stroke="#000000" bioc:fill="#ffffff" from xmlns:bioc=“” namespace (they are added because we use custom colors in our modeler). After removing these all is fine, but I wouldn’t expect that this could cause any deployment problems. I would rather expect that these attributes should be ignored by Zeebe.
Can anyone advise? Probably there should be some way to make Zeebe ignore these attributes or prevent from adding the attributes to XML?


We’d first need to understand whether this is a Zeebe limitation or a BPMN editor export bug.

Did you verify the BPMN produced with our library is BPMN 2.0 schema compliant? You could do so by piping it through a XML validator supplying the BPMN 2.0 XSD schema.

Alternatively, you can try to deploy a different diagram, let’s say a workflow that works for you and add a custom XML extension:

  <process id="Process_1" isExecutable="false" foobar:boo="1">

If Zeebe cannot deploy this one as well you simply found a missing feature in Zeebe.

From the interoperability/roundtrip perspective Zeebe should accept valid vendor extensions that it does not know.


Can you tell which Zeebe version are you running? I tried to reproduce it, but I was able to deploy a BPMN diagram with bioc included to a Zeebe 0.26.1 instance without problems.

I’m running Zeebe 0.24.3. When opening bpml with bioc attributes in Zeebe modeler - I’m getting warnings: unknown attribute [ warning ] and the deployment fails with: Command rejected with code ‘CREATE’: Expected to deploy new resources, but encountered the following errors:
‘diagram1 (17).bpmn’: SAXException while parsing input stream [ deploy-error ]
After removing all bioc elements - I’m able to deploy. Also tried to add custom extension as nikku suggested - this also works fine. Will try to upgrade to the latest Zeebe and see what happens

Getting the same for zeebe 0.26.2. Note that I’m trying to deploy from zeebe-modeler 0.11 but this I believe shouldn’t make any difference