saveXML Unhandled Rejection (Error): no definitions loaded

I’m trying to implement a react app that uses bpmn.io extension with a customizable properties panel. I was quite advanced with my implementation but suddently I came across this error. It first started when I changed some variables in my redux store (that had nothing to do with the modeler itselft) and then tried to saveXML. I tried to isolate the problem and if I run modeler.importXML and then modeler.saveXML it triggers the error.

async function importModeler() {
        await modeler.importXML(xml);
 }
async function saveModeler() {
      var saveXml = await modeler.saveXML({ format: true });
}

Calling this two functions triggers the error. I can’t find any topic related to this issue.

Please share a running / prototypical example that clearly shows what you’re trying to achieve, what is working and what is not.

Use our existing starter projects to quickly hack it or share your existing, partial solution on GitHub or via a CodeSandbox. Provide the necessary pointers that allow us to quickly understand where you got stuck.

This way we may be able to help you in a constructive manner.

Thanks :heart:

CodeSandbox

Our goal is to minimize our custom PropertiesPanel and resize the modeler container. We came across the mentioned error after minimizing and saving. Subsequently, trying to understand the issue we found that importing and then saving a xml would trigger the same error.

Thanks for the quick response.