Entries missing within Group on extending BPMN Properties Panel

I have followed the instructions in the following project to extend the bpmn-js-properties-panel to my React project.

I am able to create an extra custom group, but the entry inside the group is missing. I have attached a couple of screenshots. Is there anything specific that could cause such an issue?

Hi @bpmn1, welcome!

I think without knowing your setup / your properties provider it will be hard to tell what’s wrong. Are you able to share this, e.g. via CodeSandbox?

Hi @Niklas_Kiefer, thank you!

The code is part of a bigger project. Everything to do with the properties panel extension has been included in the above sandbox. I cant get it to run on the sandbox for some reason (i think the imports are failing) but it is working in my project.

I have tried to add a new property called ‘Condition’ under a new group ‘Properties’. The new group shows up but the property doesn’t. There’s no error showing up on the console but the entry is missing in the group. Please let me know if I’m doing something wrong or if I have to correct the sandbox anywhere.

The sandbox code is up and running now. The BPMN sample xml is currently being taken from a constants.js file and consists of a simple workflow (start > task > end).
I have tried to add a new property group to the sequence flow element.
However, on clicking the sequence flow element, I’m getting this error

Could you let me know where I might have made a error?

It seems like you are using the latest properties panel versions, but using an older API. Given the API you’re using, you should use the following dependencies

  • @bpmn-io/properties-panel version 0.10.x
  • bpmn-js-properties-panel version 1.0.0-alpha.4

The examples are not updated yet, context: https://github.com/bpmn-io/bpmn-js-examples/issues/160

Thank you, Niklas.
I have set the versions to:

  • @bpmn-io/properties-panel version 0.10.2
  • bpmn-js-properties-panel version 1.0.0-alpha.4

but now I’m getting another error in the sandbox when I click on the sequence flow.

do you know why I’m getting this error?

Could anyone please provide an update on this issue?

I have updated the libraries to:

  • @bpmn-io/properties-panel version 0.11.0
  • bpmn-js-properties-panel version 1.0.0-alpha.5

Followed the example at bpmn-js-examples/properties-panel-extension at master · bpmn-io/bpmn-js-examples · GitHub after the latest update, but I’m still getting the above mentioned error. Could anyone please let me know why this error is being thrown when I click on the sequence flow component?
Here is the sandbox for reference: bpmn-properties-extension - CodeSandbox

Thanks for sharing! I see you are using react-scripts. Since the properties panel entries need to be preact components, you need to configure your application.

Check out this thread for further help: PropertiesProvider JS definition / create-react-app 5.x - #4 by Axel_Couty

Thank you, I’ll look into configuring preact & update the status of this issue here.